Problema Consola Proxmax desde Firefox

Un cop accedeixo remotament al meu Proliant microserver de casa els meus pares, hem trobo que amb el firefox veig la consola de les maquines virtuals en blanc sense contingut.

Tot rebuscant veig que es un problema de java i per sol.lucionar el que faig es intal.lar un script que sol.luciona el problema.

Afegeixo el seguent al sources.list /etc/apt/sources.list

deb http://www.duinsoft.nl/pkg debs all

Importo la gpg key

sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 5CB26B26

sudo apt-get update

sudo apt-get install update-sun-jre

Salut !!

Share

Raspberry Pi una molt bona distribució OpenELEC

Ja he començat a jugar amb la meva Raspberry Pi (fa dos mesos que la tenia i no l’habia ni tocada) malaït temps !! on es pot comprar ???

Us puc dir que la primera opció m’ha deixat flipat ! com pot ser que funcioni amb el comandament de la tv samsung ???

Per instal.lar-lo…

ens baixem la distro…. http://sources.openelec.tv/tmp/image/openelec-rpi/

Anem a la carpeta on l’ha baixat… cd /home/username/Downloads i la descomprimim

tar xvf OpenELEC-RPi.arm-devel-20120606162014-r11258.tar.bz2

Entrem dins la carpeta creada…

cd /home/username/Downloads/OpenELEC-RPi.arm-devel-20120606162014-r11258

I ara molt de compte amb aquest pas…. cal que us assegureu on està la SD muntada… podeu mirar-ho amb el gparted per exemple, en el meu cas la tinc muntada a /dev/sdd
Arranquem script de creació de SD e instal.lació del OpenELEC (vigileu no us carregueu la unitat que no es)

sudo ./create_sdcard /dev/sdd

I ja ho tindriem, ja podem posar la SD a la raspberry i enxufar-la a la TV amb el HDMI

Per cert, si voleu remenar-hi amb ssh el password de root per defecte es openelec

Salut !!!

Share

Backup automàtic de mikrotiks dins guifi

Portava temps amb la idea de automatitzar backups de les rb’s que tinc per guifi i per fi ho estic implementant gràcies a les llistes de guifi 😉

Al servidor de casa tinc una maquina virtual amb una Mikrotik 3.20 que fare servir per recollir tots els backups de les rb’s.

Partim de la base que tant aquesta virtual com els clients tenim el SNTP configurat per tenir be el dia i hora a tot el tinglado…

A cada RB que volguem que faci backups automàtics cal introduir un script (on enlloc de xyz, hi posem el nom del node de guifi per exemple)

/system script 
add name=Backup source="/system backup save name=NomNodeGuifi" 

/system scheduler
add name="System Backup" on-event=Backup start-date=jul/03/2008 
start-time=23:15:00 interval=1w

Aqui es on li diem que ho faci un cop per setmana…

I finalment afegim l’script que l’envia i el scheduler setmanal

/system script 
add name=Fetch source="tool fetch address=IPguifiservidor 
user=***** password=****** src-path=nomdelnode.backup 
mode=ftp dst-path=nomdelnode.backup upload=yes"
/system scheduler
add name="Fetch Backup" on-event=Fetch 
start-date=jul/03/2008 start-time=23:30:00 interval=1w

Ja estaria… tansols comentar que amb el temps pot quedarse les memories de les rb’s plenes de backups i caldria anar borrant en local..
Salut !!!

Share

Rootejar Samsung Galaxy S2

Voleu instalar alguna app que es necessita root ? us copio un petit manualillo que hem va servir per fer el meu…

Rooting

  • Download this File first and put in your SDCARD
    CWM via stock recovery or download zip from http://clockworkmod.com/rommanager
    SU-Busybox-Installer.zip
  • Reboot to recovery.
  • Choose apply update from external storage.
  • Choose CWM.zip and wait until CWM recovery appear.
  • Choose install zip from sdcard or external SD
  • Choose and Install SU-Busybox-Installer.zip
  • Reboot
  • You are done and now your device is Rooted

Unroot

Share

Lliberar gratis Samsung Galaxy S2

Necessitem un samsung galaxy s2 que sigui root i fer el seguent:

Pas 1:
Instal.lar gratuitament des del market Galaxy S2 SIM Unlock

Pas 2:
Executar Galaxy S2 SIM Unlock i sel.lexionar SIM unlock code, ara tansols cal esperar que el proces arribi al 100% (entre 15 y 30 minuts)

Pas 3:
Anotar en un paper el codi entregat per Galaxy S2 SIM Unlock

Pas 4:
Apagar el telèfon, insertar una sim d’un operador diferent a l’actual e introduir el codi previament anotat.

 

Ja ho tenim, el teu Galaxy S2 ja es lliure !

Share

Trunk SIP amb SPA3000, porta el teu telefon fix a centraleta Asterisk via IP

Tret d’uns foro’s, us copio el manualillu:

IP SPA3102: 192.168.0.100
IP Asterisk: 192.168.0.200

INBOUND Trunk

  1. Acceder a la configuración avanzada y administrador, http://192.168.0.100/admin/advanced
  2. Ir a la pestaña PSTN
  3. Ir a la seccióm Proxy and Registration
  4. En proxy poner la IP del asterisk: 192.168.0.200
  5. Bajar el scroll e ir a Subscriber Information
  6. Poner User ID: PSTN
  7. Bajar a Dial Plans
  8. Ponre Dial Plan 2: (S0<:192.168.0.200>)
  9. Bajar a PSTN-To-VoIP Gateway Setup
  10. Poner PSTN CID for VoIP CID: yes (with PSTN Caller ID) / no (without PSTN Caller ID)
  11. Poner PSTN Caller Default DP: 2
  12. Bajar a FXO Timer Values (sec)
  13. Poner PSTN Answer Delay: 3 (with PSTN Caller ID) / 0 (without PSTN Caller ID)
  14. FXO Port Impedance: cambiar de 600 a 220+820||120nF
  15. SIP Remote-Party-ID: cambiar de yes a no
  16. Make Call Without Reg: cambiar a yes
  17. Ans Call Without Reg: cambiar a yes
  18. Register: cambiar a no

En Asterisk:

  1. Acceder a la configuración del FreePBX Setup.
  2. Pinchar en Trunks
  3. Pinchar en Add Trunk
  4. Pinchar en Add SIP Trunk
  5. Bajar a Inbound Settings
  6. Poner Trunk Name un nombre para el trunk, por ejemplo: TRUNKSPA3102
  7. Borrar los valores por defecto de Peer Details:, y reempazar por:
    Code:
    canreinvite=no
    context=from-pstn
    host=192.168.0.100
    insecure=very
    nat=no
    port=5061
    qualify=yes
    type=peer
    username=USER1
  8. Bajar a Incoming Settings
  9. Borrar valores por defecto de User Details:, dejarlo en blanco.
  10. Bajar scroll a la parte de abajo y pinchar en Submit Changes
  11. Pinchar en Click the You have made changes – when finished, click here to APPLY them at the top of the page.

Comprobar que nos acepta llamadas entrantes con la configuración, configurar las Inbound Routes en el interface del FreePBX, si no ponemos rutas de entrada, si no, no funcionará.

OUTBOUND Trunk

Esta es la segunda tarea, ahora que tenemos el SPA3102 con las llamadas PSTN entrantes a asterisk, ahora hay que permitir que el asterisk rute llamadas salientes hacia el SPA3102.

In reality, at this point any SIP device can send calls to the SPA-3000 and it will route them out the PSTN. Not the most secure setup, is it? After paying for someone else’s international and 900 calls that they conveniently routed through your SPA-3000 PSTN connection, you might want to consider restricting just who can use it. Here’s how:

En el SPA-3102:

  1. Acceder a Sipura SPA-3102, avanzado/administrador en http://192.168.0.100/admin/advanced
  2. Pinchar en PSTN Line tab
  3. Bajar a VoIP-To-PSTN Gateway Setup
  4. Poner VoIP Caller Auth Method: HTTP Digest
  5. Bajar a VoIP Users and Passwords (HTTP Authentication)
  6. Poner VoIP User 1 Auth ID: PSTN

En el Asterisk:

No hace falta cambios, con lo que hemos hecho en la tarea anterior es suficiente:

En Asterisk:

  1. Acceder a la configuración del FreePBX Setup.
  2. Pinchar en Trunks
  3. Pinchar en Add Trunk
  4. Pinchar en Add SIP Trunk
  5. Bajar a Outgoing Settings
  6. Poner Trunk Name un nombre para el trunk, por ejemplo: TRUNKSPA3102
  7. Borrar los valores por defecto de Peer Details:, y reempazar por:

 

Code:
canreinvite=no
context=from-pstn
host=192.168.0.100
insecure=very
nat=no
port=5061
qualify=yes
type=peer
username=USER1

No olvidar la configuración de la Outbound Route dentre del interfaz FreePBX, si no ponemos una routa de salida, asterisk no sabrá enviar una llamada hacia el SPA3102.

Share

Reparar problema unifi d’ubiquiti

Aquesta setmana m’he trobat amb el problema que al ampliar amb un nou unifi la xarxa de casa meva, no hi havia maneres d’adquirir el nou unifi v:1.3.3.3 .

Es quedava tota l’estona intentant actualitzar sense èxit.

Després de contactar amb ubiquiti, hem vàren passar aquest procediment que hem va funcionar perfectament.

1) Download the fix tool from http://dl.ubnt.com/unifi/unifimfix-1.1.2

2) Copy the fix tool to each AP individually: scp unifimfix-1.1.2 @://tmp/.

3) SSH into the device: ssh @

4) Once in the device, change the permissions of the fix tool: chmod +x /tmp/unifimfix-1.1.2

5) Execute the fix tool: ./tmp/unifimfix-1.1.2

6) Reboot the device by issuing the command: reboot

Salut

 

Share