Backups remots NFS proxmox a Qnap

Primer cal tenir accessible un servei NFS, en el meu cas l’habilito al QNAP que tinc de backups.

Llavors en el Proxmox que tinc en una altre ubicació, però que té accés a la ip del QNAP de casa meva, li afegeixo el disc NFS

Ja per últim tansols falta programar els backups que volguem al Proxmox perquè ens els faci dels CT que vulguis al disc remot NFS.

Salut !!

Share

Ubiquiti aC disable wpa2

A partir de les versions 8.5.11 no es pot desabilitar (per defecte ve amb 0000:0000) desde l’interficie web de la ràdio, per tal de poder-lo treure tens un parell d’opcions:

1 – baixar un backup, i editar la línea: aaa.status=enabled posant disable, guardar i pujar…

2 – entrar per ssh i editar /tmp/system.cfg la linea: aaa.status=enabled posant disable i guardar

ATENCIO: He trobat versions de firm que la línia en questio es: wpasupplicant.device.1.status=enabled (cal posar-la en disabled)

Salut !!

Share

Ubuntu en Macbook air, webcam

(Nota: cal tenir instal.lat curlsudo apt install curl.)

1) Clona, the bcwc_pcie driver desde https://github.com/patjak/bcwc_pcie.git

$ cd /usr/local/src
$ sudo git clone https://github.com/patjak/bcwc_pcie.git
Cloning into 'bcwc_pcie'...
remote: Enumerating objects: 8, done.
remote: Counting objects: 100% (8/8), done.
remote: Compressing objects: 100% (6/6), done.
remote: Total 1057 (delta 2), reused 4 (delta 0), pack-reused 1049
Receiving objects: 100% (1057/1057), 352.48 KiB | 537.00 KiB/s, done.
Resolving deltas: 100% (709/709), done.

2) Clona the facetimehd-firmware desde https://github.com/patjak/facetimehd-firmware into the bcwc_pcie folder

$ cd /usr/local/src/bcwc_pcie
$ sudo git clone https://github.com/patjak/facetimehd-firmware
Cloning into 'facetimehd-firmware'...
remote: Enumerating objects: 1, done.
remote: Counting objects: 100% (1/1), done.
remote: Total 886 (delta 0), reused 0 (delta 0), pack-reused 885
Receiving objects: 100% (886/886), 290.76 KiB | 294.00 KiB/s, done.
Resolving deltas: 100% (585/585), done.

3) Crea i instal.la facetimehd-firmware

$ cd /usr/local/src/bcwc_pcie/facetimehd-firmware
$ sudo make

Checking dependencies for driver download...
/usr/bin/curl
/usr/bin/xzcat
/bin/cpio

Downloading the driver, please wait...


Found matching hash from OS X, El Capitan 10.11.5
==> Extracting firmware...
 --> Decompressing the firmware using gzip...
 --> Deleting temporary files...
 --> Extracted firmware version 1.43.0

$ sudo make install
Copying firmware into '//lib/firmware/facetimehd'

4) Make and install the bcwc_pcie driver

$ cd /usr/local/src/bcwc_pcie
$ sudo make
make -C /lib/modules/5.0.0-23-generic/build M=/usr/local/src/bcwc_pcie modules
make[1]: Entering directory '/usr/src/linux-headers-5.0.0-23-generic'
  CC [M]  /usr/local/src/bcwc_pcie/fthd_ddr.o
  CC [M]  /usr/local/src/bcwc_pcie/fthd_hw.o
  CC [M]  /usr/local/src/bcwc_pcie/fthd_drv.o
  CC [M]  /usr/local/src/bcwc_pcie/fthd_ringbuf.o
  CC [M]  /usr/local/src/bcwc_pcie/fthd_isp.o
  CC [M]  /usr/local/src/bcwc_pcie/fthd_v4l2.o
  CC [M]  /usr/local/src/bcwc_pcie/fthd_buffer.o
  CC [M]  /usr/local/src/bcwc_pcie/fthd_debugfs.o
  LD [M]  /usr/local/src/bcwc_pcie/facetimehd.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /usr/local/src/bcwc_pcie/facetimehd.mod.o
  LD [M]  /usr/local/src/bcwc_pcie/facetimehd.ko
make[1]: Leaving directory '/usr/src/linux-headers-5.0.0-23-generic'

$ sudo make install
make -C /lib/modules/5.0.0-23-generic/build M=/usr/local/src/bcwc_pcie modules_install
make[1]: Entering directory '/usr/src/linux-headers-5.0.0-23-generic'
  INSTALL /usr/local/src/bcwc_pcie/facetimehd.ko
At main.c:160:
- SSL error:02001002:system library:fopen:No such file or directory: ../crypto/bio/bss_file.c:72
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: ../crypto/bio/bss_file.c:79
sign-file: certs/signing_key.pem: No such file or directory
  DEPMOD  5.0.0-23-generic
Warning: modules_install: missing 'System.map' file. Skipping depmod.
make[1]: Leaving directory '/usr/src/linux-headers-5.0.0-23-generic'

5) Habilita els drivers

$ sudo depmod
$ sudo modprobe -r bdc_pci
$ sudo modprobe facetimehd
$ sudo apt install cheese

**6) Per assegurar que facetimehd arranqui al reiniciar afegeix linea a
/etc/modules executant la comanda
sudo echo facetimehd >> /etc/modules

Share

Proxmox update non subscription package

Perquè no ens surti el molest rètol del proxmox sense subscripció

sed -i.bak "s/data.status !== 'Active'/false/g" /usr/share/javascript/proxmox-widget-toolkit/proxmoxlib.js && systemctl restart pveproxy.service

# cd /etc/apt/sources.list.d/

# cp pve-enterprise.list pve-no-subscription.list

# rm pve-enterprise.list

# nano pve-no-subscription.list

Canviar la configuració:

de – deb https://enterprise.proxmox.com/debian/pve buster pve-exnterprise

a – deb http://download.proxmox.com/debian/pve buster pve-no-subscription

Guardar i ja estaria apunt….

Ja tansols quedaria actualitzar com sempre

  • # apt update
  • # apt dist-upgrade

Share

Mikrotik The Dude Logs

A partir de la versió 6.36, canvien el sistema de logs, si abans ens els guardava en un fitxer, ara ens els posa a la memoria del mateix log de la mikrotik on tenim el dude, cosa que cada cop que la reiniciem, els perdem.

Per tal que ens quedin guardats en un .txt al mateix disc de la rb o lloc on tenim el dude muntat, tansols cal fer el seguent a la mikrotik del dude…

/system logging add topics=dude

/system logging action add disk-file-name=dude-logs-main name=dudeLogsMain target=disk

/system logging add action=dudeLogsMain topics=dude

A partir d’aquí anirà generant cada 1000 entrades un fitxer .txt a la mikrotik

Share

Multi touch pad al macbook air amb ubuntu

Doncs al final m’he decidit posar ubuntu com únic sistema operatiu al meu macbook air.

Després de que amb la “catalina” m’ha deixat de funcionar bàsicament el que més faig servir… m’ha tocat buscar info i al final m’he decidit posar el sistema operatiu que utilitzo a tots els meus pc’s desde fa molts anys.

No ha estat pas difícil, arrancant amb la tecla alt pitjada ha entrat en mode boot manager des d’on m’he carregat la partició vella. Llavors tansols he arrencat amb un usb on previament hi he posat un boot amb ubuntu 16.04 (he probat amb el 18.04 LTS, però no m’ha arrencat bé i no he insistit perquè el 16 ja hem va bé demoment.

Llavors ha estat tot “siguiente, siguiente tipic…” fins que amb poc més de 10 minuts ha estat llest.

Després d’actualitzar i fer alguns apt install …. m’he liat amb configurar el muntitouch pad que es una de les coses que més m’agrada del mac.

Si no tens git instal.lat, ja saps abans de res “apt-get install git”

git clone http://github.com/bulletmark/libinput-gestures cd libinput-gestures sudo make install

sudo apt install libinput-tools xdotool

sudo gpasswd -a $USER input # Log out and back in to assign this group

libinput-gestures-setup autostart

Al fitxer de config pots acabar de polir el que et calgui… jo tansols he modificat la part de canvi d’escriptori amb 3 o 4 dits…


cp /etc/libinput-gestures.conf ~/.config/libinput-gestures.conf nano ~/.config/libinput-gestures.conf

Reiniciar i llest

Share

Canviar firmware Ubiquiti via SSH

Bones, ahir vaig tenir problemes per actualitzar una Rocket Prism aC Gen2 via web, la única manera va ser fer-ho via ssh:

Renombrem el firmware que volguem posar-li amb el nom fwupdate.bin

El copiem via scp a la carpeta /tmp de l’antena

scp fwupdate.bin ubnt@X.X.X.X:/tmp

Ja tansols queda entrar a l’antena via ssh i executar això.

ubntbox fwupdate.real -m /tmp/fwupdate.bin

Salut !!

Share

Recuperar Fitxers SD corrupte

Bones,

Si has perdut informació d’algún SD o disc dur, per tal de recuperar les fotos, videos, fitxers d’un disc que no es monta i es corrupte, una de les maneres més fàcils amb Ubuntu es utilitzar testdisk, si no el tens instal.lat, es fàcil:

sudo apt-get install testdisk

Llavos tansols cal executar-lo desde la cònsola, escollir el /dev/sdb o el que vulguis recuperar i li especifiques una carpeta del teu home on vols que et gravi els fitxers que recupera…

També hi ha l’eina de photorec que es molt senzilla i tansols cal escollir el disc que vols comprovar i la carpeta del c on vols que ho guardi tot el que recupera

Sort !!

 

Share