Claus públiques, privades….

Els que utilitzem molt sovint ssh, es un engorro tenir que estar constantment posant usuari, password…. a tots els servidors que normalment accedim, us anoto el procediment.

Suposem que normalment utilitzes el teu portàtil, ens hi generem la clau

ssh-keygen

(ens demana 4 dades… podem anar passant sense posar-hi res)

Veurem que ens genera la nostra key privada i pública. A partir d’aquí la nostra privada ens l’hem de guardar amb pany i clau i la pública l’haurem d’anar pujant via ssh a tots els servidors nostres.

ssh-copy-id -i ~/.ssh/id_rsa.pub root@ipdesti

A partir d’aquí ja podrem accedir des del nostre portàtil a tots els servidors directament sense posar passwords.

Salut !

Share

Ubiquiti Airvision NVR v:2.x

Aquesta setmana he posat en marxa el nou NVR d’ubiquiti per grabar les 4 camares de l’hort, tot perfecte, es una meravella, super petit, potent i silenciós.

El problema ha estat el poder visualitzar les càmares en remot desde guifi, he redirigit els ports 7443, 843, 7080 al nvr i podia accedir al airvision, però no veia les imatges. (curiòs perque a casa ho tinc aixi i funciona)

Resulta que porta una versió 2.x vs la 1.x que tinc a casa i segons he llegit necessita també redirigir el port 1935. Ho he fet i voilà…. perfecte !!

Salut !!

Share

Convertir Picostation M2 amb Unifi

Oficialment es permet canviar de firm fàcilment, tansols cal pujar el firm unifi a la picostation mitjançant el airos. El pots trobar aquí

Tingues en compte que a partir del canvi els leds es comportaràn de diferent manera.

Hi ha maneres de tornar enrera i carregar un altre cop el firm del airos, però cal fer-ho per tftp, aqui ho expliquen: http://community.ubnt.com/t5/Installation-Troubleshooting/Howto-recover-Picostation-M2/td-p/286807

Salut !

Share

Servidor d’impressio Cups per casa

Citació

Fa temps que el tenia muntat al servidor amb una virtual… fins que ha petat el disc i no tenia backup… o sigui que tornem-hi….

Tinc una Brother MFC-490CW en xarxa i el servidor de casa un HP Proliant amb Proxmox.

Primer creo un contenedor nou al proxmox amb un debian7 i li configuro la xarxa a /etc/network/interfaces

Entro per ssh, com sempre (ssh root@ipdelavirtual)

Actualitzo amb apt-get update i apt-get upgrade

Instal.lo Cups amb apt-get install cups

Modifico el fitxer de configuracio del cups per poder accedir a la interficie web de configuracio i control amb nano /etc/cups/cupsd.conf

Cal canviar on posa Listen localhost:631 per Listen *.631

I a les restriccions d’accés que venen entre <Location> cal afegir la linea a sota “Allow from all” també a la de <Location admin>

Guardem canvis i reiniciem el servei amb /etc/init.d/cups restart

Ja hauriem de poder accedir del navegador amb http://ipdelcups:631

Ja podeu afegir la impressora/impressores i configurar-lo com volgueu

Jo ho he tingut mes complexe perque no hi habien els drivers de la meva, els he aconsseguit de http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#MFC-490CW

Els baixeu i els copieu al Cups, ja sabeu… els .deb i els instal.leu amb dpkg -i

A partir d’aqui ja els tenim, si tot va bé hauria de funcionar

Salut !!

Share

Overclocking a una Raspberry Pi amb Openelec

Arran d’uns talls en reproduir un .mkv d’alta definició vaig mirar de sol.lucionar el problema i vaig fer les seguents proves amb molts bon resultats.

Aquest tipus de minipc, no disposa de bios, cosa que l’overclock l’hem de fer des del mateix arranc que tinguem a la sd.

En aquest cas jo utilitzo Openelec i el que cal es modificar els paràmetres a un fitxer config.txt dins de la carpeta /flash

Per poder-ho fer cal modificar els permisos de la carpeta (recordeu que per defecte l’usuari root té el password openelec)

Entrem per ssh

ssh root@ipraspberry

mount /flash -o remount,rw

nano /flash/config.txt

A partir d’aqui busquem les seguents linees, les descomentem i les modifiquem a gust del consumidor us poso d’exemple tal i com jo la he deixada:

arm_freq=950
core_freq=450
sdram_freq=450
over_voltage=6

El mode màxim recomanat seria fins a 1000 la velocitat del arm i 500 tant el core com sdram…

Salut !!

Share

Failover senzill amb mikrotik

Aquest es un exemple per fer failover entre dues connexions, ja siguin fisiques o tunelitzades, tansols cal que tingueu en compte les interfícies utilitzades…

En aquest cas farem un check amb les ip’s seguents

8.8.8.8       Google-DNS  host1A
72.30.2.43    Yahoo       host1B

8.8.4.4       Google-DNS host2A
199.59.148.82 Twitter    host2B

Primer cal posar les rutes necesàries (adapteu les gateways vostres…)

/ip route
add dst-address=8.8.8.8 gateway=192.168.1.1 scope=10
add dst-address=72.30.2.43 gateway=192.168.1.1 scope=10
add dst-address=8.8.4.4 gateway=192.168.2.1 scope=10
add dst-address=199.59.148.82 gateway=192.168.2.1 scope=10

Creo unes destinacions virtuals…

/ip route
add dst-address=10.1.1.1 gateway=8.8.4.4 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.1.1.1 gateway=72.30.2.43 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.2.2.2 gateway=8.8.8.8 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.2.2.2 gateway=199.59.148.82 scope=10 target-scope=10 check-gateway=ping

I ara hi aplico les rutes marcades

/ip route
add distance=1 gateway=10.1.1.1 routing-mark=to_ISP1
add distance=2 gateway=10.2.2.2 routing-mark=to_ISP1
add distance=1 gateway=10.2.2.2 routing-mark=to_ISP2
add distance=2 gateway=10.1.1.1 routing-mark=to_ISP2

Enmascaro les interfícies

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

Amb això tindriem lo bàsic, llavors podem jugar amb fer llistes de adresses per anar per un o altre isp..

Salut !!

 

Share