Instal.lar Aircontrol 2 en un debian 7

Entrem com sudo

apt-get update; apt-get install openjdk-7-jre traceroute iperf
wget http://www.ubnt.com/downloads/aircontrol2/aircontrol-v2.0–ubuntu.deb
dpkg -i aircontrol-v2.0–ubuntu.deb

Canvier l’enllaç per la versió que us interessi… jo he provat la beta 15

Si voleu passar les dades d’una màquina a una altre heu de passar els arxius de la carpeta /opt/Ubiquiti/AirControl2/lib/db

Salut !!

Share

Problema Poe de les Mikrotik UPA

Aquesta setmana m’he trobat un problema al actualitzar Omnitik UPA i rb750 UPA, al passar a la 6.7 i firm 3.10 els poe’s es tornen inestables, tot el que hi ha alimentat està constantment reiniciant, amb el problema que això suposa.

A partir d’aqui després de mil proves (no hi ha cap versio més nova) la una sol-lució que he trobat es fer un downgrade a la 6.5 i copiant la seguent ordre:

/interface ethernet poe settings upgrade

Aixi actualitzem la part poe i ja no falla més.

Salut !!

 

Share

Recuperar antena Ubiquiti per tftp

A vegades ens podem trobar amb una antena que s’hagi quedat tonta i no respongui ni a resets… podem mirar de recuperar-la carregant el firm per tftp de la seguent manera:

Sense alimentar clicar al reset, alimentar i als 8 segons deixar anar el reset perque quedi en mode programació (hauria de respondre a pings) si respon a pings podem anar per fer el seguent: (penseu a baixar-vos la darrera versió de firm…)

root@ubuntu:tftp 192.168.1.20
tftp> bin
tftp> trace
tftp> put XS2.ar2316.v3.4-rc.4351.090504.2146.bin
Sent 1965199 bytes in 35.2 seconds
tftp> exit

Salut !

Share

Problema amb el ssh-copy-id en un mac

Els usuaris de linux que fem servir també un mac, hem de tenir en compte que el paquet ssh-copy-id no existeix com a paquet…. així que podem fer un inventillu…

Obrim terminal i creem un nou fitxer:

sudo nano /usr/bin/ssh-copy-id

On hi copiem el seguent codi:

#!/bin/sh

# Shell script to install your public key on a remote machine
# Takes the remote machine name as an argument.
# Obviously, the remote machine must accept password authentication,
# or one of the other keys in your ssh-agent, for this to work.

ID_FILE=”${HOME}/.ssh/id_rsa.pub”

if [ “-i” = “$1” ]; then
shift
# check if we have 2 parameters left, if so the first is the new ID file
if [ -n “$2” ]; then
if expr “$1” : “.*.pub” > /dev/null ; then
ID_FILE=”$1″
else
ID_FILE=”$1.pub”
fi
shift # and this should leave $1 as the target name
fi
else
if [ x$SSH_AUTH_SOCK != x ] && ssh-add -L >/dev/null 2>&1; then
GET_ID=”$GET_ID ssh-add -L”
fi
fi

if [ -z “`eval $GET_ID`” ] && [ -r “${ID_FILE}” ] ; then
GET_ID=”cat ${ID_FILE}”
fi

if [ -z “`eval $GET_ID`” ]; then
echo “$0: ERROR: No identities found” >&2
exit 1
fi

if [ “$#” -lt 1 ] || [ “$1” = “-h” ] || [ “$1” = “–help” ]; then
echo “Usage: $0 [-i [identity_file]] [user@]machine” >&2
exit 1
fi

{ eval “$GET_ID” ; } | ssh ${1%:} “umask 077; test -d .ssh || mkdir .ssh ; cat >> .ssh/authorized_keys” || exit 1

cat <<EOF
Now try logging into the machine, with “ssh ‘${1%:}'”, and check in:

.ssh/authorized_keys

to make sure we haven’t added extra keys that you weren’t expecting.

EOF

 

Ho guardem amb ctrl+x, sortim i donem permisos al fitxer:

$ sudo chmod +x /usr/bin/ssh-copy-id

A partir d’aquí ja ho podem utilitzar com amb un linux

$ ssh-copy-id usuario@host

Salut !!

 

Share

Claus públiques, privades….

Els que utilitzem molt sovint ssh, es un engorro tenir que estar constantment posant usuari, password…. a tots els servidors que normalment accedim, us anoto el procediment.

Suposem que normalment utilitzes el teu portàtil, ens hi generem la clau

ssh-keygen

(ens demana 4 dades… podem anar passant sense posar-hi res)

Veurem que ens genera la nostra key privada i pública. A partir d’aquí la nostra privada ens l’hem de guardar amb pany i clau i la pública l’haurem d’anar pujant via ssh a tots els servidors nostres.

ssh-copy-id -i ~/.ssh/id_rsa.pub root@ipdesti

A partir d’aquí ja podrem accedir des del nostre portàtil a tots els servidors directament sense posar passwords.

Salut !

Share

Ubiquiti Airvision NVR v:2.x

Aquesta setmana he posat en marxa el nou NVR d’ubiquiti per grabar les 4 camares de l’hort, tot perfecte, es una meravella, super petit, potent i silenciós.

El problema ha estat el poder visualitzar les càmares en remot desde guifi, he redirigit els ports 7443, 843, 7080 al nvr i podia accedir al airvision, però no veia les imatges. (curiòs perque a casa ho tinc aixi i funciona)

Resulta que porta una versió 2.x vs la 1.x que tinc a casa i segons he llegit necessita també redirigir el port 1935. Ho he fet i voilà…. perfecte !!

Salut !!

Share

Convertir Picostation M2 amb Unifi

Oficialment es permet canviar de firm fàcilment, tansols cal pujar el firm unifi a la picostation mitjançant el airos. El pots trobar aquí

Tingues en compte que a partir del canvi els leds es comportaràn de diferent manera.

Hi ha maneres de tornar enrera i carregar un altre cop el firm del airos, però cal fer-ho per tftp, aqui ho expliquen: http://community.ubnt.com/t5/Installation-Troubleshooting/Howto-recover-Picostation-M2/td-p/286807

Salut !

Share

Failover senzill amb mikrotik

Aquest es un exemple per fer failover entre dues connexions, ja siguin fisiques o tunelitzades, tansols cal que tingueu en compte les interfícies utilitzades…

En aquest cas farem un check amb les ip’s seguents

8.8.8.8       Google-DNS  host1A
72.30.2.43    Yahoo       host1B

8.8.4.4       Google-DNS host2A
199.59.148.82 Twitter    host2B

Primer cal posar les rutes necesàries (adapteu les gateways vostres…)

/ip route
add dst-address=8.8.8.8 gateway=192.168.1.1 scope=10
add dst-address=72.30.2.43 gateway=192.168.1.1 scope=10
add dst-address=8.8.4.4 gateway=192.168.2.1 scope=10
add dst-address=199.59.148.82 gateway=192.168.2.1 scope=10

Creo unes destinacions virtuals…

/ip route
add dst-address=10.1.1.1 gateway=8.8.4.4 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.1.1.1 gateway=72.30.2.43 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.2.2.2 gateway=8.8.8.8 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.2.2.2 gateway=199.59.148.82 scope=10 target-scope=10 check-gateway=ping

I ara hi aplico les rutes marcades

/ip route
add distance=1 gateway=10.1.1.1 routing-mark=to_ISP1
add distance=2 gateway=10.2.2.2 routing-mark=to_ISP1
add distance=1 gateway=10.2.2.2 routing-mark=to_ISP2
add distance=2 gateway=10.1.1.1 routing-mark=to_ISP2

Enmascaro les interfícies

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

Amb això tindriem lo bàsic, llavors podem jugar amb fer llistes de adresses per anar per un o altre isp..

Salut !!

 

Share