Ubiquiti Airvision NVR v:2.x

Aquesta setmana he posat en marxa el nou NVR d’ubiquiti per grabar les 4 camares de l’hort, tot perfecte, es una meravella, super petit, potent i silenciós.

El problema ha estat el poder visualitzar les càmares en remot desde guifi, he redirigit els ports 7443, 843, 7080 al nvr i podia accedir al airvision, però no veia les imatges. (curiòs perque a casa ho tinc aixi i funciona)

Resulta que porta una versió 2.x vs la 1.x que tinc a casa i segons he llegit necessita també redirigir el port 1935. Ho he fet i voilà…. perfecte !!

Salut !!

Share

Convertir Picostation M2 amb Unifi

Oficialment es permet canviar de firm fàcilment, tansols cal pujar el firm unifi a la picostation mitjançant el airos. El pots trobar aquí

Tingues en compte que a partir del canvi els leds es comportaràn de diferent manera.

Hi ha maneres de tornar enrera i carregar un altre cop el firm del airos, però cal fer-ho per tftp, aqui ho expliquen: http://community.ubnt.com/t5/Installation-Troubleshooting/Howto-recover-Picostation-M2/td-p/286807

Salut !

Share

Failover senzill amb mikrotik

Aquest es un exemple per fer failover entre dues connexions, ja siguin fisiques o tunelitzades, tansols cal que tingueu en compte les interfícies utilitzades…

En aquest cas farem un check amb les ip’s seguents

8.8.8.8       Google-DNS  host1A
72.30.2.43    Yahoo       host1B

8.8.4.4       Google-DNS host2A
199.59.148.82 Twitter    host2B

Primer cal posar les rutes necesàries (adapteu les gateways vostres…)

/ip route
add dst-address=8.8.8.8 gateway=192.168.1.1 scope=10
add dst-address=72.30.2.43 gateway=192.168.1.1 scope=10
add dst-address=8.8.4.4 gateway=192.168.2.1 scope=10
add dst-address=199.59.148.82 gateway=192.168.2.1 scope=10

Creo unes destinacions virtuals…

/ip route
add dst-address=10.1.1.1 gateway=8.8.4.4 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.1.1.1 gateway=72.30.2.43 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.2.2.2 gateway=8.8.8.8 scope=10 target-scope=10 check-gateway=ping
add dst-address=10.2.2.2 gateway=199.59.148.82 scope=10 target-scope=10 check-gateway=ping

I ara hi aplico les rutes marcades

/ip route
add distance=1 gateway=10.1.1.1 routing-mark=to_ISP1
add distance=2 gateway=10.2.2.2 routing-mark=to_ISP1
add distance=1 gateway=10.2.2.2 routing-mark=to_ISP2
add distance=2 gateway=10.1.1.1 routing-mark=to_ISP2

Enmascaro les interfícies

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

Amb això tindriem lo bàsic, llavors podem jugar amb fer llistes de adresses per anar per un o altre isp..

Salut !!

 

Share

Com canviar a Compliance Test una Ubiquiti Spain

Doncs bé, arrel de les darreres versions del Airos un cop escollit un pais, no ens deixa cambiar-lo a menys que no li fem un reset de fàbrica.

Un truquillo es baixar la configuració i editar el fitxer .cfg canviant el codi de pais 724 per el 511 (en versions 5.X) o 5000 (en versions 7.X).

Grabar i pujar….

En cas de no sortir, sempre queda l’opció de fer:

touch /etc/persistent/ct

save

reboot

 

Salut !

Share

Zenoss a una Debian/Ubuntu

Avui he instal.lat un Zenoss a un contenedor del meu servidor Proxmox.

La instal.lació del contenedor… com sempre aquest cop fent servir un template d’una Debian 6.

Un cop posada en marxa hi he posat dues interficies de xarxa, una per la meva local i l’altre per guifi amb una IP accessible per cada costat…

He entrat per ssh al contenedor i he afegit al /etc/apt/sources.list

deb http://dev.zenoss.org/deb main stable
$ sudo apt-get update
$ sudo apt-get install zenoss-stack

Amb això ja el tenim instal.lat i accessible al port 8080

Salut !!

 

Share

Configurar proxy desde consola linux

Editar els seguents arxius canviant lo blau per lo vostre…

sudo nano /etc/bash.bashrc

Posar el seguent al final

export http_proxy=http://username:password@proxyserver.net:port/
export https_proxy=http://username:password@proxyserver.net:port/
export ftp_proxy=http://username:password@proxyserver.net:port/

Editar l’arxiu /etc/environment

sudo nano /etc/environment

Posar aixo al final

http_proxy=http://username:password@proxyserver.net:port/
https_proxy=http://username:password@proxyserver.net:port/
ftp_proxy=http://username:password@proxyserver.net:port/

Editar l’arxiu /etc/apt/apt.conf

sudo nano /etc/apt/apt.conf

Posar al final

Acquire::http::Proxy “http://username:password@proxyserver.net:port“;
Acquire::https::Proxy “http://username:password@proxyserver.net:port“;
Acquire::ftp::Proxy “http://username:password@proxyserver.net:port“;

Salut !!!

 

Share

Imatges Asteroide 2012 DA14 via Guifi.net

Dins el projecte europeu Gloria, es pot fer el seguiment amb imatges captades de l’asteroide 2012 DA14 desde diversos llocs d’europa.
Entre ells (l’ultim de la llista) hi ha el de Girona al Penihttp://guifi.net/peni
Els responsables del projecte necessitaven accés a internet a dalt la muntanya on a part de guifi.net no hi ha gaire res més…
Els hi hem fet un tunel a una adsl propera y ara les imatges s’envien a temps real gràcies a guifi.net per ftp a un servidor d’on la Nasa en captura les imatges.
Salut !!
Share

Migrar AirControl de servidor Linux

Estic canviat de server, i avui he canviat el servei d’aircontrol de server, he estat buscant la opció de backup/restore i no hi es. Hi tinc moltes coses com per tenir que tornar a entrar-les totes de nou !

…. les passes que he seguit han estat:

Muntar paquet aircontrol al nou server

Parar el servei al nou server /etc/init.d/aircontrol stop

Copiar del antica servidor la carpeta /usr/share/aircontrol/data al nou server

I ja podem arrencar el servei al nou server amb /etc/init.d/aircontrol start

Ja tenim al nou server, tot lo antic !

Salut !!

Share